Temporary System Interruption
Incident Report for TazWorks
Resolved
This incident has been resolved.
Posted Sep 11, 2019 - 10:06 MDT
Monitoring
Users may experience a temporary system interruption between 5:00 and 5:30 PM MDT. If they are logged out, they will be able to log in immediately after.
Posted Sep 10, 2019 - 16:43 MDT
This incident affected: TazWorks.