MeridianLink Statuspage
All Systems Operational

About This Site

This Statuspage provides the status of MeridianLink's products.
Customers may click "Subscribe to Updates" and select specific Product Components to receive email notifications for if there is a service disruption.

MeridianLink Consumer / MeridianLink Opening ? Operational
Consumer App Operational Status Operational
Consumer App Credit Reports Operational
Consumer App Fraud Prevention Vendors Operational
Consumer App Indirect Auto Integrations Operational
Consumer App Vehicle Valuation Operational
Consumer App Underwriting & Pricing Engine Operational
Consumer App - Other Partner Integrations Operational
Consumer App Core Integration Operational
Consumer App Documents Operational
Consumer App Reports Operational
MeridianLink Mortgage Operational
Mortgage App LOS Operational
Mortgage App EDocs Operational
Mortgage App Pricing Engine (PML) Operational
Mortgage App Integrations Operational
Mortgage App Reporting ? Operational
Mortgage App TPO Portal Operational
MeridianLink Mortgage Credit Link Operational
Mortgage Credit Link App Operational Status Operational
Mortgage Credit Link Credit Integrations Operational
Mortgage Credit Link Additional Product Integrations Operational
MeridianLink Collect Operational
Collect App Operational Status Operational
Collect App Internal Integrations ? Operational
Collect App External Integrations ? Operational
MeridianLink Portal Operational
Portal App Operational Status Operational
Portal App Credit Reports Operational
Portal App Fraud Prevention Vendors Operational
Portal App eSign Operational
Portal App Underwriting & Pricing Engine Operational
Portal App - Other Partner Integrations Operational
Portal App Core Integration Operational
Portal App Portal Manager Operational
Portal App SSO Operational
Portal App Documents Operational
MeridianLink DecisionLender Operational
DecisionLender4 App Operational Status Operational
DecisionLender4 Reporting DBS Operational
DecisionLender4 Partner Integrations Operational
DecisionLender3.5 App Operational Status Operational
DecisionLender3.5 Reporting DBS Operational
DecisionLender3.5 Partner Integrations Operational
MeridianLink Engage Operational
Engage App Operational Status Operational
MeridianLink Insight Operational
Insight Operational Status Operational
Data Refresh Operational
TazWorks Operational
InstaScreen Operational Status Operational
InstaScreen Partner Integrations Operational
QuickApp Pro/QuickLease Pro Operational Status Operational
Trade House Data Searches Operational
MeridianLink Business Operational
Atlas Platform Operational
Credit Card Application Operational
Business Lending Application ? Operational
Offer and Closing Operational
Cloudflare Cloudflare Workers Operational
Cloudflare CDN/Cache Operational
MeridianLink Mortgage OpenClose/Access/Optics/CAW Operational
OpenClose Operational
OpenClose Pricing Engine (DecisionAssist) Operational
Mortgage Access Operational
Mortgage Optics Operational
ConsumerAssist Web Operational
General Operational
Global Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
We will be performing system maintenance on EPL and Dedicated production environments - after business hours. This is to install the MS security patch for the current month.

This maintenance is scheduled to begin at 7 pm (PT) for east coast environments. For other environments we will proceed with the update after COB for that timezone. During this time, each environment will be down for approximately 30-40 minutes.

Posted on Apr 01, 2024 - 09:00 PDT
Past Incidents
Apr 18, 2024

No incidents reported today.

Apr 17, 2024
Completed - The scheduled maintenance has been completed.
Apr 17, 23:00 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 17, 19:00 PDT
Scheduled - We will be performing system maintenance on all shared production server environments - after business hours. This maintenance is scheduled for 7 pm (PT). During this time, each environment will be down for approximately 30-40 minutes. Note: CS will begin at 8PM (PT), the Secure, HS and WS server maintenance will start at 9 pm (PT).
Apr 15, 09:37 PDT
Resolved - This incident has been resolved.
Apr 17, 13:35 PDT
Identified - We are in contact with Tessera Data and they are working on the issue.
Apr 16, 13:04 PDT
Investigating - We are currently investigating the issue.
Apr 16, 08:23 PDT
Resolved - This incident has been resolved.
Apr 17, 07:53 PDT
Investigating - We received several reports from customers indicating that they are receiving an error when attempting to pull Experian PreciseID. MeridianLink Support has contacted Experian and Experian is investigating the issue.
Apr 16, 06:38 PDT
Resolved - This incident has been resolved.
Apr 17, 05:58 PDT
Update - April 16, 2024
Update: Today we were alerted by Sisense, a third-party business intelligence and analytics for MeridianLink Insight, that they have contained their recent security incident. As such, we are pleased to let you know that we have re-established connectivity with Sisense.
When we were made aware of this incident, we reset keys, tokens, and credentials as advised by Sisense. We remain committed to the security of your information and continue to work with Sisense in support of the ongoing security and availability of your data.

Apr 16, 14:59 PDT
Update - April 15, 2024
Update: We are working with third-party business intelligence and analytics vendor, Sisense, to understand the scope of their incident. We will not turn Insight back on until we are confident in the ongoing security of our customers’ data. At this time, we do not have confirmation from the vendor on whether any MeridianLink Insight data was involved in their incident. We will share additional information with you as we receive it.

Apr 15, 11:10 PDT
Update - We are continuing to work on a fix for this issue.
Apr 15, 11:09 PDT
Update - We are continuing to work on a fix for this issue.
Apr 11, 06:18 PDT
Identified - The issue has been identified and a fix is being implemented.
Apr 11, 06:07 PDT
Apr 16, 2024
Resolved - TazWorks Insights is now back online and available, and we have communicated directly with CRAs utilizing the product. Thank you for your patience.
Apr 16, 15:18 PDT
Identified - TazWorks Insights reporting is currently offline and unavailable. We will share additional information with impacted CRAs as we receive it.
Apr 15, 14:35 PDT
Resolved - This issue is considered resolved.
Apr 16, 13:55 PDT
Monitoring - We have implemented a workaround resolution to continue processing these trigger files while TransUnion fixes the root cause on their end. We have requested TransUnion to resend files from 4/8 so that we can reprocess those.
Apr 12, 09:44 PDT
Identified - We've been engaging with Transunion throughout the day today, and the cause of the UDN issue has been identified. We will provide further updates as they come.
Apr 10, 15:00 PDT
Investigating - We are working with TransUnion to resolve an issue with TransUnion UDNs not processing updates or status changes. We will update the status here as this progresses.
Apr 9, 14:54 PDT
Resolved - We were able to work with our platform vendor to resolve this issue, and the Knowledge Base is now accessible from Instascreen again.
Apr 16, 13:36 PDT
Investigating - We are currently investigating an issue with errors accessing the Knowledge Base from Instascreen. We are working with our platform vendor and will provide updates as we receive them.
Apr 15, 14:36 PDT
Apr 15, 2024
Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024
Apr 11, 2024
Apr 10, 2024
Apr 9, 2024
Apr 8, 2024
Resolved - This incident has been resolved.
Apr 8, 07:03 PDT
Monitoring - A fix has been implemented and we are continuing to monitor for any further issues.
Apr 8, 06:28 PDT
Investigating - We are currently investigating the reports of system latency.
Apr 8, 06:00 PDT
Apr 7, 2024

No incidents reported.

Apr 6, 2024

No incidents reported.

Apr 5, 2024
Resolved - This incident has been resolved.
Apr 5, 09:47 PDT
Monitoring - We've received reports from several users of being able to successfully pull JD Power for Powersports.
We will continue to monitor the situation.

Apr 4, 15:03 PDT
Investigating - We have received reports of users receiving an error when attempting to pull JD Power for Powersports.
We are currently investigating this issue.

Apr 4, 08:37 PDT
Resolved - We have received confirmation that Demo is functioning as expected. This incident has been resolved.
Apr 5, 09:43 PDT
Monitoring - A fix has been implemented and we are monitoring the results.
Apr 4, 10:46 PDT
Investigating - We have received reports regarding an error when saving or booking applications: Error saving app: Unexpected execution.
This is happening in Demo.

Our technical team is working on a solution to the issue.

Apr 4, 09:50 PDT
Apr 4, 2024
Resolved - This incident has been resolved.
Apr 4, 07:56 PDT
Investigating - We are investigating a delay in the data refresh for April 4, 2024.
Apr 4, 06:04 PDT