Calls and Emails Not Working
Incident Report for TazWorks
Resolved
Our ticketing system is now functioning as expected and our support team can now be reached. Thank you for your patience.
Posted about 1 month ago. Sep 16, 2019 - 13:19 MDT
Identified
We are currently experiencing an outage with our ticketing system. As such, new calls and emails are not reaching our team. In the interim, please leave a voicemail and we will reach out to you as soon as the system is operational. Thank you for your patience.
Posted about 1 month ago. Sep 16, 2019 - 12:19 MDT
This incident affected: TazWorks.